All systems operational

Completed
Essential Maintenance

Status
Resolved after about 1 hour
Started
21 October 2022 at 6:00:00 PM
Completed
21 October 2022 at 6:48:00 PM
Affects
JobWatch
Client Site
  • Completed
    21 October 2022 at 6:47:55 PM

    This Maintenance has been completed successfully.

  • In progress
    21 October 2022 at 6:00:01 PM

    Maintenance is now in progress

  • Planned
    21 October 2022 at 6:00:00 PM

    We are carrying out some essential maintenance work on our servers this evening between 7pm and 8pm (BST). User's may experience some latency during this period but the system should remain operational.