www.bigchange.com website maintenance
Scheduled for 23 February 2023 at 9:00:00 PM – 9:38:37 PM
Affects
BigChange
Under maintenance from 9:00 PM to 9:38 PM
Client Site
Under maintenance from 9:00 PM to 9:38 PM
Completed
23 February 2023 at 9:38:37 PMCompleted
23 February 2023 at 9:38:37 PMMaintenance has completed successfully.
In progress
23 February 2023 at 9:00:01 PMIn progress
23 February 2023 at 9:00:01 PMMaintenance is now in progress
Planned
23 February 2023 at 9:00:00 PMPlanned
23 February 2023 at 9:00:00 PMWe are performing maintenance on our Client Site during the period mentioned.
During this time, errors may be experienced when attempting to load the main bigchange.com website.
If issues are experienced when loading www.bigchange.com, please navigate to the following address to access the BigChange Portal
https://clients.bigchange.com/