BigChange Ltd - Tracking Device Connection issues – Incident details

All systems operational

Tracking Device Connection issues

Resolved
Degraded performance
Started 12 days agoLasted 1 day

Affected

BigChange

Degraded performance from 2:13 PM to 6:01 PM

Tracking Services

Degraded performance from 2:13 PM to 6:01 PM

Updates
  • Resolved
    Resolved

    This issue is now resolved and SIMs are connecting normally

  • Identified
    Identified

    Our SIM provider has applied some changes and we are starting to see the impacted devices send back their data

  • Investigating
    Investigating

    We are aware of some customer reports of some tracking devices not reporting information, this has been raised to our 3rd party SIM provider for further investigation