BigChange Ltd - Tracking Device Connection issues – Incident details

All systems operational

Tracking Device Connection issues

Resolved
Major outage
Started about 8 hours agoLasted about 6 hours

Affected

BigChange

Major outage from 9:38 AM to 3:24 PM

Tracking Services

Major outage from 9:38 AM to 3:24 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are aware of some customer reports of some tracking devices not reporting information, this has been raised to our 3rd party SIM provider for further investigation