BigChange Ltd - Phone line issue – Incident details

All systems operational

Phone line issue

Resolved
Major outage
Started about 21 hours agoLasted about 1 hour

Affected

Support

Major outage from 9:10 AM to 10:08 AM

Help Guide

Major outage from 9:10 AM to 10:08 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently experiencing a technical issue affecting our phone lines. Our team are liaising with our 3rd party provider to resolve the problem. Please use our email support for immediate assistance. We apologize for the inconvenience.