All systems operational

Microsoft 365 service issues

Resolved
Operational
Started over 1 year ago Lasted about 2 hours

Affected

JobWatch
Client Site
Updates
  • Resolved
    Resolved

    This issue has now been resolved.

  • Monitoring
    Monitoring

    Microsoft 365 is currently experiencing a service disruption which is impacting email delivery. Unfortunately this means our support team may not be receiving any emails sent to them this morning. Until this issue is resolved we advise contacting roadcrew on 0113457100 for any support issues.