All systems operational

Xero Integration Synchronisation Delay

Resolved
Operational
Started 7 months ago Lasted 29 minutes

Affected

JobWatch
Client Site
Updates
  • Resolved
    Resolved

    Our engineers have confirmed that this issue is now resolved.

    If any invoices are currently sat in an "Awaiting Sync" state, please edit and save the invoice to resend to Xero.

    If the issue persists, please contact Support.

  • Identified
    Identified

    Our team have identified an issue that is affecting the syncing of contacts and financial documents to Xero.

    A further update will be provided in 30 minutes.