All systems operational

Mobile Data Connection Issue

Resolved
Operational
Started 5 months ago Lasted about 2 hours

Affected

JobWatch
Mobile Application Services
Updates
  • Resolved
    Resolved

    Our 3rd party SIM provider has confirmed the issue is now resolved.

  • Investigating
    Investigating

    BigChange have received reports from customers relating to Mobile Data Connectivity on BigChange Devices.

    We have escalated this to our 3rd party SIM provider and awaiting a response.

    Another update will provided as further detail is made available.