All systems operational

JobWatch Mobile Application - Issue opening Google Maps.

Resolved
Operational
Started about 1 month ago Lasted about 4 hours

Affected

JobWatch
Mobile Application Services
Updates
  • Resolved
    Resolved

    Our Support team have confirmed that all required updates to Managed Devices have been successfully deployed and this issue is now resolved.

  • Identified
    Identified

    Our Support teams are aware of an issue opening Google Maps from the JobWatch Mobile Application.

    An update to managed devices is currently being deployed.

    If issues persist, please contact the BigChange Support Team.