BigChange Ltd - Intermittent Connectivity Issues Affecting Support Centre – Incident details

All systems operational

Intermittent Connectivity Issues Affecting Support Centre

Resolved
Operational
Started 5 months agoLasted about 4 hours

Affected

Support

Operational from 9:13 AM to 12:43 PM

Support Portal

Operational from 9:13 AM to 12:43 PM

Updates
  • Resolved
    Resolved

    Our engineers have confirmed the issue is now resolved.

  • Monitoring
    Monitoring

    We are currently experiencing intermittent connectivity issues within our support centre, this is resulting in poor call quality and occasional dropped calls. 

    Our engineers are actively investigating the root cause of the problem.

    To avoid any delay in our response, we recommend submitting a ticket through our Support Portal - https://support.bigchange.com