BigChange Ltd - Issues accessing and generating Reports – Incident details

All systems operational

Issues accessing and generating Reports

Resolved
Operational
Started about 1 month agoLasted 33 minutes

Affected

JobWatch

Operational from 3:33 PM to 4:05 PM

Client Site

Operational from 3:33 PM to 4:05 PM

Updates
  • Resolved
    Resolved

    This issue is now resolved.

  • Identified
    Identified

    Our engineers have identified the issue and are actively working on resolving this.

  • Investigating
    Investigating

    Our engineers are currently investigating this incident.