BigChange Ltd - Microsoft Office BigChange Word Add-in – Incident details

All systems operational

Microsoft Office BigChange Word Add-in

Resolved
Operational
Started about 2 months agoLasted about 2 hours

Affected

JobWatch

Partial outage from 1:58 PM to 4:25 PM

Microsoft Office Add-ins

Partial outage from 1:58 PM to 4:25 PM

Updates
  • Resolved
    Resolved

    Our team have received confirmation that this issue is now resolved.

  • Identified
    Identified

    Our team is aware of an issue affecting the loading of the Microsoft Office BigChange Word Add-in. This issue has been identified as being related to a broader Microsoft outage, which is impacting the performance and functionality of our Microsoft Office app.

    The team are actively monitoring the situation and will provide further updates as soon as the issue is resolved or if there are any significant developments.