Scheduled for 03 August 2025 at 12:00:00 PM – 2:00:00 PM
Affects
BigChange
Under maintenance from 12:00 PM to 2:00 PM
Client Site
Under maintenance from 12:00 PM to 2:00 PM
Background Services
Under maintenance from 12:00 PM to 2:00 PM
Tracking Services
Under maintenance from 12:00 PM to 2:00 PM
Web Services
Under maintenance from 12:00 PM to 2:00 PM
Updates
Completed
03 August 2025 at 2:00:00 PM
Completed
03 August 2025 at 2:00:00 PM
Maintenance has completed successfully
In progress
03 August 2025 at 12:00:01 PM
In progress
03 August 2025 at 12:00:01 PM
Maintenance is now in progress
Planned
03 August 2025 at 12:00:00 PM
Planned
03 August 2025 at 12:00:00 PM
Our engineering team will be performing essential system maintenance to improve performance and reliability.
During this two-hour period, you may experience brief service interruptions, delays with tracking data or temporary slowdowns. No action is required on your part; services will return to normal automatically.
If you encounter any persistent issues after the maintenance has concluded, please contact our support team at +44 (0) 113 457 1000.